Back to overview
Degraded

Sporadic delay in events delivery

Jun 02 at 07:05am EDT
Affected services
Delivery HTTP Uptime
Queueing

Resolved
Jun 03 at 08:00pm EDT

The database issue that was causing latency spikes in delivery is now resolved. We will follow up with a full post mortem.

Updated
Jun 03 at 08:28am EDT

At this point we believe we identified the cause of the performance degradation in our databases.
Our provider is working on building a new instance with the correct setting applied. This will likely take another few hours as it's a large database. We'll keep providing updates as we get new information. We'll also provide a full post mortem once this incident is resolved.

Created
Jun 02 at 07:05am EDT

We're experiencing sporadic delay in delivering events. We tracked the root cause to an issue with a database upgrade. We are working on a fix.