Back to overview
Degraded
Isseu with bulk operations on free and starter plans
Oct 31 at 07:30am EDT
Affected services
Delivery HTTP Uptime
Resolved
Oct 31 at 08:11am EDT
The delivery latency issue has been resolved, we're monitoring the fix
Affected services
Created
Oct 31 at 07:30am EDT
Bulk operations (cancel, retry) are currently unstable, and latency is higher than usual on free and starter plans
Affected services