Back to overview
Degraded

We are experiencing webhook delivery latency

Nov 29 at 09:30am EST
Affected services
HTTP Delivery

Resolved
Nov 29 at 10:45am EST

We have identified the root cause, and have processed our backlog. Delivery is back to normal

Created
Nov 29 at 09:30am EST

Delivery of webhooks is impacted