Some attempts are unexpectedly timing out
Resolved
Dec 08 at 07:53pm EST
We traced the issue back to Heroku-hosted URLs. Heroku is having a router incident https://status.heroku.com/, so Hookdeck is behaving as intended. However, our Mock API is currently hosted on Heroku, so users using the Mock API will also have been impacted by those timeouts.
Affected services
HTTP Delivery
Updated
Dec 08 at 07:32pm EST
Only a small subset of destinations are impacted, with most timeouts originating form our Mock API (https://mock.hookdeck.com). We are still investigating the root cause.
Affected services
HTTP Delivery
Created
Dec 08 at 07:20pm EST
We are investigating an issue were attempt are timing out regardless of the destination responsiveness. This seems to be caused by a networking problem within GCP. If you have a retry logic enabled, attempts will be retried. Otherwise you can bulk retry once the problem is fully resolved.
Affected services
HTTP Delivery