Back to overview
Downtime

SSL Error causing HTTP redirect on ingestion endpoint

Mar 14 at 06:32pm EDT
Affected services
HTTP Ingestion

Resolved
Mar 14 at 06:33pm EDT

The configuration change has been reverted, and the redirect no longer occurs. Full postmortem here: https://www.notion.so/hookdeck/2023-03-14-SSL-Configuration-Change-6e1151229ff1480a9cb818f2afd652a5

Created
Mar 14 at 06:32pm EDT

We modified an SSL configuration which caused our ingestion endpoint (events.hookdeck.com) to incorrectly return a 301 status code. This lasted for about 2 minutes, at which point we reverted the configuration. However, during that time we failed to ingest webhooks sent to our platform. For most, if the calling party followed redirects, hookdeck will have responded with a 405, the result of following the redirect with a GET.