Back to overview
Degraded

Delivery latency increase

Jan 25 at 03:03pm EST
Affected services
Delivery HTTP Uptime

Resolved
Jan 25 at 03:51pm EST

Service has been restored

Created
Jan 25 at 03:03pm EST

On January 25, 2025, between 19:03-19:51 UTC, we experienced elevated delivery latency peaking at 45 seconds, with intermittent fluctuations throughout the incident window. The service has since returned to normal operation.