Back to overview
Degraded
Dashboard data is experiencing latency, we are working on a fix
Jul 22 at 05:00pm EDT
Affected services
Dashboard
Resolved
Jul 22 at 05:55pm EDT
Dashboard latency is back to normal.
Affected services
Dashboard
Created
Jul 22 at 05:00pm EDT
Dashboard data and reporting are delayed. Delivery is not impacted.
Affected services
Dashboard