HTTP 500 errors on ingestion
Resolved
Nov 04 at 09:17am EST
Full post-mortem here: https://hookdeck.notion.site/HTTP-Ingestion-Outage-2a2783a05de280838ec6eba29de797bf
Affected services
Created
Nov 04 at 09:15am EST
Our ingestion endpoints (hkdk.events, events.hookdeck.com, or your custom domain) returned a high number of 500 errors for 2 minutes and 11 seconds from 2025-11-04T14:15:09Z to 2025-11-04T14:17:22 after an update. We immediately rolled back the deployment and are investigating the root cause of the issue. This means that requests received during that time were not processed. If your provider offers retries, your requests will have been processed on the first retry.
SLA credits will automatically be added to accounts for customers under SLA guarantees.
We're incredibly sorry for the trouble caused. We've had years of operation without downtime on our ingestion; we will learn from this mistake and implement additional safeguards.
Affected services