Back to overview
Degraded

Delivery latency increase

Mar 30, 2026 at 05:03pm UTC
Affected services
Delivery HTTP Uptime

Resolved
Mar 30, 2026 at 05:27pm UTC

We've identified the issue, and the services have recovered. We've now caught up on the backlog the issue caused.

CORRECTION: The previous update incorrectly stated that the issue affected all customers; it was, in fact, limited to free and team plan customers and did not impact customers under SLAs (growth & enterprise)

Created
Mar 30, 2026 at 05:03pm UTC

We are investigating a delivery latency issue affecting free and team plan customers. Our team is currently investigating. We will update as soon as we have more information.