Back to overview
Degraded

Increased delivery latency

Jun 16, 2026 at 2:09pm UTC
Affected services
Event Delivery

Resolved
Jun 16, 2026 at 2:21pm UTC

From 2:09 pm UTC to 2:20 pm UTC, we experience increased delivery latency (p99 of ~5 minutes at its worst). A DB switchover, which is normally transparent and doesn't impact latency, left some workers in a crashed state and failed to recover automatically. We're looking into the root cause of why the workers crashed and did not recover.

Created
Jun 16, 2026 at 2:09pm UTC

We're seeing increased latency in event delivery and are investigating the root cause.