Back to overview
Resolved

Ingestion degradation affecting part of inbound traffic

Jul 8, 2026 at 6:18pm UTC
Affected services
Event Delivery

Resolved
Jul 8, 2026 at 9:17pm UTC

The incident affecting us-east5 has been resolved. The request backlog was processed, and no requests were lost during this incident.

Updated
Jul 8, 2026 at 7:23pm UTC

We have recovered, and delivered all of the events that were in our backlog. No events were lost. The Google Cloud incident is still active, we'll keep this issue open until the incident on Google's end is resolved.

Updated
Jul 8, 2026 at 6:57pm UTC

We have confirmed that the issue is on our provider's side (GCP). Global dynamic routing and VPC connectivity to us-east5 is affected. This is an emerging issue. No events are lost, as events are properly ingested and queued, and we will deliver them as soon as issues are resolved. We will keep updating this issue as we learn more.

Created
Jul 8, 2026 at 6:18pm UTC

We are experiencing an issue where we're unable to consume traffic coming through GCP region us-east5. This is affecting 8-10% of our inbound traffic. We are therefore unable to deliver that traffic as a consequence. We are working on root cause analysis and resolution. No events are lost, as events are properly ingested and queued. We will keep posting updates here.